読者です 読者をやめる 読者になる 読者になる

Redmine 0.9.2 をインストール

Redmine 0.9 が正式にリリースされたので、Ubuntu マシンで動いてた 0.8.7 から 0.9.2 にアップグレードしてみました。

基本的に http://www.redmine.org/wiki/redmine/RedmineUpgrade の通りに。

webrick ではちゃんと動いたんですが、Apache + Passenger だと動きませんでした。Redmine 0.9.2 に含まれている Rails のバージョンと Passenger があっていなかったためのようです。
Ubuntu 9.10 の Passenger は 2.0.3 ですが、最新は 2.2.9 のようなので、それにしてみました。

Ubuntu の Passenger を削除:

# aptitude purge libapache2-mod-passenger

Gem で Passenger をインストール:

# gem install passenger
# passenger-install-apache2-module

"Please edit your Apache configuration file, and add these lines:" の後に表示される行を Apache の設定ファイルに追加します。Ubuntu の作法にならって、/etc/apache2/mods-available/passenger.load を作成してそこに記述しました。

LoadModule passenger_module /usr/lib/ruby/gems/1.8/gems/passenger-2.2.9/ext/apache2/mod_passenger.so
PassengerRoot /usr/lib/ruby/gems/1.8/gems/passenger-2.2.9
PassengerRuby /usr/bin/ruby1.8
# a2enmod passenger

そして、"Deploying a Ruby on Rails application: an example" の出力にならって、/etc/apache2/sites-available/redmine を変更しました。

<VirtualHost *:80>
   ServerName redmine.example.com
   DocumentRoot /var/www/redmine/public
   <Directory /somewhere/public>
      AllowOverride all
      Options -MultiViews
   </Directory>
</VirtualHost>
# a2ensite redmine

そして、http://redmine.example.com/ にアクセスすると…

404 Page not found ... orz

ここで1時間ほど悩んだんですが、 http://www.shige.idani.jp/tdiary/?date=20090421 このページで答えが見つかりました。
redmine/public/.htaccess の RewriteRule をコメントアウトすることで正常に動作させることができました。

30分もあれば楽勝くらいに考えていたんですが1時間半も掛かってしまいました。まあ、動いたからOKです。原因が分からなかった時は 0.8 に戻さないといけないかと思っていたので。

ところで、0.8 では「Target version」だったのが 0.9 では日本語に訳されて「対象バージョン」となりました。
ん〜、これはビミョーですねぇ…。バグチケットの場合は修正されるバージョンを記入すると思うんですが、「対象バージョン」だとバグが発生したバージョンに思われかねないなぁ…と。

いい訳は思いつかないんですけど、たとえば「目標バージョン」とか…。